Skip to main content

How to delete Azure Active-Directories

When I was trying to delete an Azure Active-irectory by using the management portal I have received the error message “Directory contains one or more applications that were added by a user or administrator” and I was really confused.

Then I found out this is a common issue. The solution was even more confusing, some PowerShell cmdlets are needed. Unfortunately I was not able to proceed, it was not possible to login with my Microsoft-ID to execute the needed commands.

Here I found out I have to install the correct version of the tools. These are located here.

Popular posts from this blog

How to get started with Windows Server AppFabric easily

In my opinion it is really hard to get started with Windows Server AppFabric. There is good material, but it is shuffled around in different sources. A good intro can you find here: this all-in-one intro by Scott Hanslmann  this caching intro by Wade Wegener  Additional helpful resources are Microsoft's Introduction Part 1 and Microsoft's Introduction Part 2 by Jon Flanders  Pluralsight's Hosting Fundamentals   Pluralsight's Caching Introduction   Microsoft's Caching Documentation   Good books are Microsoft Windows Server AppFabric Cookbook   and Pro Windows Server: AppFabric Please also watch out for software updates, currently there is CU 4 . To keep yourself updated subscribe to Distributed Services News Feed . Updated my list on 11.03.2014 with one more Download the Windows Server AppFabric Samples

How to fix Windows Server AppFabric Dashboard on Windows Server 2012 / Windows 8

Windows Server AppFabric is a great enhancement for IIS and its caching capabilities are great for .NET applications. But currently there is a very annoying bug regarding its monitoring UI, so called “Dashboard”. Especially for me as a non WF guy (I am actually just working with WCF) it was really hard to figure it out. Hence, many thanks to Gianluca from Distributed Services at Microsoft! Windows Server AppFabric Dashboard does not work on Windows Server 2012 / Windows 8. You will receive this error message "Unable to cast object of type 'System.Management.Automation.PSCustomObject' to type 'Microsoft.ApplicationServer.Management.Data.GroupByInfo'." This error will cause that you cannot see any request statistics neither WF nor for WCF: The reason is, I quote Microsoft here: "[...] the root cause is a powershell script embedded in AF code that returns different results when ran on Windows 2012. This script is about statistics for Idle & per...